Basic requirements for installing Stages Cycling app version 3.0.0. 


Download the app


Android device requirements


Minimum operating system

  • Android 7.0


Permissions requirements

  • Camera: Used to scan QR codes for Dash pairing. 
  • Location: Location services must be permitted and enabled on Android devices in order for the app to use Bluetooth. 
  • Storage: For saving and uploading of activity files. 
  • Other: Access to Bluetooth, Wi-Fi, vibration, receiving data from the internet, full network access, and other features required for the functionality of the app. 


Device feature requirements

  • Bluetooth LE (4.0 or higher)
  • Camera
  • Wi-Fi
  • GPS
  • Portrait display
  • Touchscreen


No eligible devices for app install

If the Android app store says you have no devices eligible for app install, your devices may be on an unsupported version of the Android operating system. Stages Cycling app for Android currently requires an operating system of Android 7 or better. Some devices have a custom implementation of Android that may be missing requirements to run the Stages Cycling app. To check for your operating system version, go to Settings > About Phone > Software information*.

To check for software updates or install a new update, go to Settings > Software update > Download and install*.


*Location of software version or updates may vary from device to device and across Android versions.

iOS device requirements


Minimum iOS Version: 12.0


Minimum macOS Version: 11.0


Compatible with both iPhone and iPad device families. 


 

Other problem?


For additional help, please open up a support ticket with Stages Cycling and provide information regarding your specific device (manufacturer and model) and operating system.